Version 3 of the selector library features a completely redesigned API designed for for better performance and more advanced developers, rather that users. Much of the idiot-proofing and type-checking has been stripped out, if you're an idiot don't use this version.